Jump to content
SNS Users' Forums
  • Announcements

    • Eric Newbauer

      Follow SNS on Twitter!

      Get notifications via Twitter! Looking for instant updates? We're now also announcing new versions and beta programs via Twitter. Follow Studio Network Solutions on Twitter. Thanks!
glennv

any command line to refresh readonly mounted share ?

Recommended Posts

Have lots of issues with readonly mounted xtarget share not auto updating while set to every 30 seconds. Part of render farm so clients do not see new source material unless manualy refreshed using synch button on iSANmp client.

So is there some command i can put in the crontab to just trigger it that way ?

Share this post


Link to post
Share on other sites

Hi Glenn,

The SANmp Admin and Client guides have a reference section for the command line interface, if you'd like to set it up that way. Otherwise, you could configure an Auto Sync interval in SANmp Admin. Please see the guide for details about the use of this feature before configuring it.

Share this post


Link to post
Share on other sites

Hi Glenn,

We see now that you said you had autosync set to 30 seconds. The "autosync" feature in SANmp Client is intended to do exactly what you want. After the autosync interval is set in SANmp Admin, the SANmp Client workstations would need to log out and back in again to see the change.

It's possible that the sync is being prevented under normal usage. If any application has a file or folder open on the volume that will prevent the sync from completing properly. You note that sync works properly if done manually. Are you doing anything different when using the manual sync process, such as closing out of applications?

Thanks,
Jason

Share this post


Link to post
Share on other sites

Hi Guys,

Tnx for the replies. It may be related to open files as after carefull inspection the manual sync (the sync button the in the sanmp client) also did not work most of the times. Only a full remount worked. Thats a bit the chicken and egg problem. You set the interval to 30 seconds as you expect lost of changes that you need to have available on all read only nodes, but these same changes lock the sync mechanisme apparently.  So a single file in use will lock the sync for the whole filesystem ??? Bummer......

p.s. before you ask , had already disabled spotlight for all volumes as is a known culprit. Also disabled Amphetamine (an app to keep my raid array spinning 24x7 and prevents sleep). 

Share this post


Link to post
Share on other sites

×