Jump to content
SNS Users' Forums
  • Announcements

    • Eric Newbauer

      Follow SNS on Twitter!

      Get notifications via Twitter! Looking for instant updates? We're now also announcing new versions and beta programs via Twitter. Follow Studio Network Solutions on Twitter. Thanks!

Recommended Posts

OS X Mavericks was released today.


We have been testing the current publicly available version/build of the globalSAN Initiator (v.5.1.1.423) with the various developer preview releases of 10.9 provided by Apple over the last few months, and we currently know of one issue that affects all users:


This issue affects all unsigned kexts in all versions of OS X 10.9 previews:

  • There are warnings in the logs: WARNING - Invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext "/System/Library/Extensions/globalSAN.kext"

  • If the OS is updated, a window may be displayed with the list of unsigned extensions that include globalSAN.kext


We understand some users prefer to upgrade to a new OS version right away. With all upgrades, we suggest taking a pragmatic approach, which includes having a current backup of your system in case there are unforeseen problems.


It is impossible for us to test with all available iSCSI targets, so we ask that if you have problems w/ Mavericks please reply to this thread with details of your issue.


We are finalizing a new version of the initiator (v.5.2) with some new features, including the official support for OS X Mavericks with signed kexts. Please watch our Product Announcements and Twitter feed for more information.

Share this post


Link to post
Share on other sites

Hi,

After upgrading to Mavericks, i am no longer able to see iSCSI drive in finder. If i go in to system preferences, it shows that i am connected and everything if without issue.

Dave

Share this post


Link to post
Share on other sites

Net even getting to that stage. Pref panel crashes with :

Process: System Preferences [503]
Path: /Applications/System Preferences.app/Contents/MacOS/System Preferences
Identifier: com.apple.systempreferences
Version: 12.0 (12.0)
Build Info: SystemPrefsApp-259000000000000~23
Code Type: X86-64 (Native)
Parent Process: launchd [419]
Responsible: System Preferences [503]
User ID: 501
PlugIn Path: /Library/Frameworks/Xtarget.framework/Versions/A/Xtarget
PlugIn Identifier: com.sns.Xtarget
PlugIn Version: 1.0 (1)
Date/Time: 2013-10-25 12:32:26.476 +0200
OS Version: Mac OS X 10.9 (13A603)
Report Version: 11
Anonymous UUID: 3B04608F-7097-6441-3312-08C67AE97249
Crashed Thread: 0 Dispatch queue: com.apple.main-thread
Exception Type: EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000010
VM Regions Near 0x10:
-->
__TEXT 0000000101fc6000-0000000101fe8000 [ 136K] r-x/rwx SM=COW /Applications/System Preferences.app/Contents/MacOS/System Preferences
Application Specific Information:
com.sns.preference.globalSAN v.5.1.1.423 (globalSAN iSCSI Initiator and Xtarget)
objc[503]: GC: forcing GC OFF because OBJC_DISABLE_GC is set

So yes please to a Maverick version. All my other software works fine so just waiting for you guys to do the upgrade ;-)

Share this post


Link to post
Share on other sites

Done (3 days ago)

Any guestimates on the ETA of a Maverick supporting driver (or at least a decent beta ) , as you probably have been working on this for a while now (since Apple has given all developers lots of betas to test against )?

I am sure there are a lot of people waiting for this as besides all the useless gimmick and crappy IOS-afication that prevented me from moving to Mountain Lion, the new memory compression in Maverick seems to work magic in some high memory load scenarios , and improved multi screen support is a good one as well, so definately want to switch asap.

Share this post


Link to post
Share on other sites

Just an fyi for others with issues. A normal uninstall of the driver lots of times does not remove all files from your system (depending on your driver update / install / uninstall history).

So after a normal uninstall with the uninstall app in /Applications/globalSAN, make sure you also check the following from terminal:

sudo rm -rf /System/Library/Extensions/globalSAN.kext
sudo rm -rf /Library/Preferences/com.sns.globalSAN.plist
sudo rm -rf /Library/Preferences/com.sns.preference.Xtarget.plist
sudo rm -rf /Applications/globalSAN

Then do a search for '*iSCSI*', '*globalSAN*', '*globalsand*', '*SNSArchitectureModel*' , "*studionetwork*" and manually remove any associated files. (if you have other sns solutions installed like SANMP, be carefull not to remove components of those, or like i did just reinstall all those as well )

You are likely to find the following which should be removed.

/sbin/globalsand
/Library/LaunchDaemons/com.sys.globalSAN.plist
/System/Library/Extensions/SNSArchitectureModel.kext

Then reboot and reinstall the current version.

What i did notice is that after the upgrade my read speeds dropped by more then 20-30% on the same LUN's , which is a bit worry-some as this has been a problem child of globalsan initiator (specialy but not exclusively with synology ), so i hope the developes will release a proper Maverick optimized version that not brings us back into those dark ages ;-)

I would say if you have similar experiences let SNS know so they can work on that if not already done in next driver.

Lets wait and see when the new promised driver is released. So far it is at least somewhat workable.

Share this post


Link to post
Share on other sites

Hi there,

i got two feedbacks.

First scenario -> just updated from ML to Mav right form the Appstore. All Targets (QNAP TS-259Pro+ with 2 Seagate ST2000DM001 at RAID1) stay connected. No access problems.

But one problem persists and this is very annoying. Nearly every 3-5 Minutes i get the notification from mavericks, that the device or storage medium (name of one of the two connected targets) has been ejected incorrect. (i don`t know the right wording, because i´m on a german mavericks install) But the QNAP is still powered on - an the "normal file shares" on AFP are connected and could be accessed.

Second scenario --> i made a fresh and clean install of mavericks to exclude problems from upgrading ML to Mav.

But now i got a another Problem. just adding the QNAP IP and search doesn't work. Everytime i get the following error:

Connection Error

CODE E3FF8301 - The iSCSI service or target is not currently operational.

Now i always have to type this very long LUN-adress e.g. iqn.2004-04.com.qnap:ts-259proplus..... (with ML oder Lion this was not necessary - just typed the NAS IP @ Group - scan and got the LUNs.

And - just for log - the problem with the annoying mavericks notifications (storage medium has been ejected incorrect) is here still persistent.

Hopefully you fix it soon - its very annoying because i can't only deactivate "finder-notification" in notification-setup :( if i want to deactivate it, i have to deactivate all notifications (Facebook, calendar, reminders ... )

Share this post


Link to post
Share on other sites

I am using the GlobalSAN initiator (5.1.1.243) on two Macs (2010 Mac Pro and 2009 iMac) to a Synology DS-1512 target. This was working fine under 10.8 Mountain Lion. I updated the Mac Pro to 10.9 Mavericks and have been having 4 separate problems:

1: Kernel panics (2 so far). I don't know what triggers it as both times I was away from the machine and returned to find the Mac Pro had rebooted. The com.sns.driver.SnsiSCSI driver shows up in the call stack.

2: Sleep/wake problems. Well, mostly the Mac Pro won't go to sleep on its own. "pmset -g log" says, assertion status system-wide listed by owning process: "pid 16(powerd): [0x000000090000013d] 101:07:22 ExternalMedia named: "com.apple.powermanagement.externalmediamounted" -- I don't have any other external media so I presume this is talking about the iSCSI volume. Ejecting the iSCSI volume (from the finder) is not enough to make this assertion go away, but if I eject the volume then go to the "globalSAN iSCSI Initiator" prefpane and disconnect the target in the "initiator" tab, then the assertion goes away.

3: "Disk Not Ejected Properly" warnings -- if the computer does manage to sleep, when it wakes up I usually get a notification from Finder titled "Disk Not Ejected Properly" and saying "Eject <name of my iSCSI volume> before disconnecting or turning it off".

4: Sometimes the iSCSI volume is mounted and all the files and directories show up, but the file contents are empty or corrupted. When this happens, ejecting the volume and reconnecting to it shows the correct file contents.

This is a pretty dismal result so far; I'm hoping the Mavericks update to your software can address all this very soon.

Share this post


Link to post
Share on other sites

Update:

i can agree with metamatt - same for me - 3-4 kernel panics.

--> 3) - that's exactly what i get too - and i have to made a news-update. It really disconnects the iSCSI-Drives.

One LUN used to host my iPhoto-library. And when i open iPhoto it loads for a few minutes (large library) and then it says "iPhoto library is not available" - and at the same time i get the "Disk not ejected properly" notification by mavericks.

and in this case this is a unacceptable problem which must be fixed very very soon.

Share this post


Link to post
Share on other sites

Hello metamatt and Maddeen (and others),

We do appreciate your feedback. The more environments where we can see our software run (or attempt to run), the better we can identify and fix any problems. It would further be helpful if you would open a support case with us so that we can more easily keep track of who has tried what.

Thanks for your help,

Jason

Share this post


Link to post
Share on other sites

I understand that this needs work and work needs investment. Why are you not doing the obvious thing of running a kickstarter campaign to fund the work? You pay, you get the upgrade early, you don't pay, then you wait. If the KS campaign is not a success, by which i mean that it can't pay for the long term staffing invested needed, then it shows that it is not really that important to people, so you can take your time. I for one would pay a little to mean i can upgrade to the latest OSX on launch day, maybe I am alone, but you will only find that out if you open it up to the market.

Bellyaching does not write software.

Share this post


Link to post
Share on other sites

At the moment I am still using OSX 10.8.5 because of the above issues with Maverick.

I am using the GlobalSAN initiator v5.1.0.400 in my private environment - under these

conditions, it was a "big" investment for me. If I pay for a software I expect that the developers

keep up with the development of the supported operating systems - I think every customer

think so, therefore it is not uncommon. Furthermore I think Apple does support developers

very well in the run - so I not really understand why there is still no version of the

GlobalSAN initiator, which supports Maverick. I hope we will see some improvements

in the near future - otherwise I would be very disappointed.

@seamus: I totally disagree - what the h.e.l.l has kickstarter to do with the development of a established product like GlobalSAN initiator ? :angry:

Share this post


Link to post
Share on other sites

Can we have a date for a Mavericks compatible release?

One day? One week? One month? One year?

I've got 3 os x server. I already updated 2 server (without iscsi) to Mavericks and os x server 3, now I really want to update my last server (the one with iscsi) but i'm waiting for the new v.5.2 of the initiator.

I'm tired to look everyday for news on snsforum.

Please give us informations about the Mavericks compatible version of the initiator as soon as possible.

Please give us a date.

Thanks.

Share this post


Link to post
Share on other sites

Please be a bit professional and give us an ETA

Not working here on 10.9 Server with QNAP TS459U+

Have been waiting too long to migrate 2 servers.

Thanks

Panix

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×